Intermittent Connectivity Issues - Telia
Incident Report for CubedHost, LLC
Resolved
Connectivity issues have subsided at this time. We'll continue to monitor.
Posted about 1 month ago. Nov 03, 2018 - 23:25 UTC
Monitoring
We're monitoring global intermittent connectivity problems due to currently unknown network routing issues with upstream provider Telia. This may impact your connection to some Minecraft servers until the issue is resolved.
Posted about 1 month ago. Nov 03, 2018 - 21:59 UTC