Some new orders not provisioning automatically
Incident Report for CubedHost, LLC
Resolved
This incident has been resolved.
Posted Jun 03, 2021 - 02:23 UTC
Identified
We've identified an issue after the migration of our billing system that has resulted in some new orders not being provisioned automatically. If you've placed an order for a new server, it may not provision immediately as is intended. We are monitoring incoming orders and will manually process any that fail to provision.

Unexpected behavior, or inability to access your service, should be reported to support@cubedhost.com.

Our ETA to resolve this issue is within 24 hours.
Posted May 25, 2021 - 15:13 UTC