Miami, FL - UPS Maintenance
Incident Report for CubedHost, LLC
Resolved
The maintenance has been completed. Thank you for your patience in this matter!
Posted about 1 month ago. Aug 16, 2019 - 19:46 UTC
Investigating
Our Miami, FL location is under an emergency maintenance to resolve some power issues.
Posted about 1 month ago. Aug 16, 2019 - 14:00 UTC
This incident affected: Prisma - Game Hosting Platform (Miami, FL, USA).